cancel
Showing results for 
Search instead for 
Did you mean: 

Updates from older software versions now available!

Highlighted
Wizard

Updates from older software versions now available!

Great news!!!

I have just updated the Samsung Epic Maintenance Release blog with the info noted below.  In summary, those who have devices on a prior software version (DG17, DG27, DI07, DI18, EB13) will be able to update via OTA to the newest EC05 release.  See the thread on the EC05 release here

Note that the leaked DK28 release is not supported by Sprint and cannot be updated via OTA - whatever method was used to update to DK28 can be used to update to one of the official releases, which will then be eligible for the OTA updates. 

UPDATE 3/24/11

:  Updates from older versions are now available via OTA.  If you are on any of the previous releases (not including the leaked DK28 release), you will receive a notification to update...still following

   up on whether these will be step releases (DG27 to DI07 to DI18, etc.) or if they will be from the old release directly to the current (for  example, DG27 to EC05).

45 REPLIES 45
Journeyman

Updates from older software versions now available!

This is great news! Any information as to timeframe? I have a DG17 that hasn't ever received ANY of the prior updates, and I've been really frustrated over the last few weeks with the Froyo madness.

Journeyman

Updates from older software versions now available!

Heh, this just made me think.  The whole freaking fiasco is not because we're excited to get Froyo.  That's a joke when Honeycomb is the true buzzword which might perhaps be exciting. 

The reason we're so damn eager to get Froyo is because ECLAIR and Samsung's Frankenstein cobbling of it ABSOLUTELY SUCKS!!!!!

Journeyman

Updates from older software versions now available!

dshoem01, you've been a nice reference to have around. 

I'm hoping you can provide some sort of pointer to how I can get off of DK28.  Especially after your last post!

Do I have to root?

Do I have to use clockworx?

Do I have to replace the apparently crappy cable (since I can't seem to get Odin to work?)

Do I have to use Odin?

Is there anybody who can walk us DK users back from this mess with the least damage? 

What is the difference between "flash", "root", "tar", "rom", "modem", "zip", "update.zip", in the context of the Epic 4G?

Thanks!

I'm really starting to feel like I'm on Window ME here...

Journeyman

Updates from older software versions now available!

Samsung does not give a shtick about CURRENT customers.  The EPIC is one of the most expensive phones via sprint....I WASTED $250 on buying this phone only to be shafted by inferior software.  FROYO was out for about 4 months before this phone released.  That should have been a warning. Samsung to current owners "Because you suck, and we hate you"  I heard one say something like 'we already got your money, if you want 2.2, buy another phone at full price!'

Journeyman

Updates from older software versions now available!

20 after 4 AM Eastern Standard Time on 3/25/2011...still no update notice or update found.  I'm VERY disappointed.

Journeyman

Updates from older software versions now available!

Hi , I have EB13 on my phone and have not received the EC05 update yet... I tried the instructions you gave

[2.  Tap Menu > Settings > About phone > System updates >Update Android]

and nothing...

any other suggestions?

Journeyman

Updates from older software versions now available!

Ok Honeycomb is only for Tablute Devices. Gingerbread is for phones. Now on the gingerbread Realize site it does say the Epic will get it. Which i imagine if they do it, it will be sometime this summer. but there isnt much difference from what im reading from the Froyo and gingerbread. just bear with Sprint and Samsung, there doing there best and will have stuff out soon, I presonally Love my Epic. of Course i just came from a moment so.

Journeyman

Re: Updates from older software versions now available!

Epic is an appropriate name for this phone because it is an Epic Fail! There are phones out now running 3.0! When will we get that? Probably next year!

Journeyman

Updates from older software versions now available!

brettlingle wrote:

Epic is an appropriate name for this phone because it is an Epic Fail! There are phones out now running 3.0! When will we get that? Probably next year!

Is your phone not working ok?

Journeyman

Updates from older software versions now available!

omar_basspr wrote:

Hi , I have EB13 on my phone and have not received the EC05 update yet... I tried the instructions you gave

[2.  Tap Menu > Settings > About phone > System updates >Update Android]

and nothing...

any other suggestions?

Same here. I am on stock EB13 and as of today (03/25/11) the phone has not show any indication of trying to update to EC05. 

I think (judging from my experience, and from the comments I am reading here) that there is a real problem to be looked into with regards to updating from EB13 to EC05.  I don't think we've seen hardly anyone with EB13 who says they got the EC05 update pushed to them in the last few days.  I hope we can get some updated information some time soon regarding this specific aspect of the update. Thank you.

Journeyman

Updates from older software versions now available!

About the DG17. After 3 calls to Sprint ( one of which they disconnected me), talking with 4 different people, I was so happy to learn that the phone I spent $499.99 for will not be updateable.  Thanks Sumsung, Sprint and Google ! It looks like to same type of stuff that drove me from Microsoft to Apple and now the IPhone sure is looking good.

Community News

Sprint S.M.A.R.T Agents
Sprint S.M.A.R.T Agent are here to help Monday through Sunday 6:00 AM CT - 6:00 PM CT. If you need to speak to an agent outside of these hours, please visit Sprint Chat