cancel
Showing results for 
Search instead for 
Did you mean: 

MTB USB Device driver fails to load after 4.4/Kies update

Journeyman

MTB USB Device driver fails to load after 4.4/Kies update

After updating my GS3 to 4.4.2, I launched KIES as was advised of an update. I updated without a problem however now my GS3 will not connect. It gets an error trying to load the MTB USB device driver. I've uninstalled and reinstalled KIES, rebooted the phone, uninstalled and reinstalled the phone drivers and all the above. No change. Anyone else seeing the same and/or have a fix?

Thanks

6 REPLIES 6
Master

Re: MTB USB Device driver fails to load after 4.4/Kies update

Thanks for posting StvnM

I know that this can definitely be frustrating, I know that when this happened to me uninstalling and re-installing the drivers actually fixed it but I see that is not the case for you. Have you tried a hard reset on your device? Let me know!

Krishel
Social Care
Journeyman

Re: MTB USB Device driver fails to load after 4.4/Kies update

The device has been reset and no change.

Thanks

Master

Re: MTB USB Device driver fails to load after 4.4/Kies update

Thanks for the update StvnM

Have you tried to use a different USB cord by chance? Do you have another phone you can use to hook up to the computer to see if the drivers work? Is there another computer you can also use to try to hook your current device up to to see if it may be the computer you're using? I just want to factor out everything first.

Krishel
Social Care
Journeyman

Re: MTB USB Device driver fails to load after 4.4/Kies update

My wife's phone updated last night and one of my daughters this morning. They have the same problem. So different, phones, different computers, different cords. And yes, we're using the cord that came with the phone. I rarely use KIES so this is not a huge inconvenience, but worth noting there is a problem.

Thanks

Master

Re: MTB USB Device driver fails to load after 4.4/Kies update

Thank you for bringing this to our attention StvnM

Krishel
Social Care
Highlighted
Journeyman

Re: MTB USB Device driver fails to load after 4.4/Kies update

So, it appears Samsung may have released an updated version of KIES today. On another blog, someone noted having the same issue and I followed their steps.

1. Uninstall KIES

2. Uninstall Samsung Drivers

3. Reboot

After reboot ..

1. Reinstall KIES

2. Launch KIES and accept UPDATE

3. After updating, plug phone in and it worked.

Oddly, when you download KIES initially from samsung.com/kies, it is not the latest v3 version. You have to launch KIES to get it to install the latest version. I can now also access the phone via File Manager.

As always, your mileage may vary. Good luck!

Community News

Need Help? 
Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base.
If you have an account question you can create a post and one of our Social Care Agents will help you.
If you need immediate assistance please visit Sprint Chat