Sprint Community is currently read-only. Please use the My Sprint app or Sprint.com to manage your account. If you need assistance, please visit Sprint.com/chat
Sprint Community is currently read-only. Please use the My Sprint app or Sprint.com to manage your account. If you need assistance, please visit Sprint.com/chat
Sprint Community
cancel
Showing results for 
Search instead for 
Did you mean: 

TeleNav issue

Go to solution
Journeyman

TeleNav issue

Is anyone else having issues with TeleNav on their SG3? I was able to use it two weeks ago but now it won't let me get past a premium upgrade screen. I have tried clearing the data, unistalling and reinstalling but still no luck.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Journeyman

Re: TeleNav issue

Hey everyone - Thanks for your patience while we looked into this. I'm happy to let you know that this issue has been fixed.

If you're still seeing this problem, please don't hesitate to let me know by emailing me at kenjio at telenav dot com. By my estimates though, I don't believe anyone is running into this issue anymore.

Thanks again, everyone, for your patience and for using our app. We think you rock.

Kenji from Telenav

View solution in original post

14 REPLIES 14
Highlighted
Master

Re: TeleNav issue

So sorry that you're having issue with the Telenav! Are you talking about the stock Telenav app or app that you've downloaded from Google Play Store? I would suggest you to clear the cookies and clear data from the applications- manage application-all apps- Telenav gps navigator-tap on the app. Reboot your phone and update profile. If these steps don’t resolve, you would need to reset the phone to avoid premium upgrade screen. Let me know.

Abe

Highlighted
Journeyman

Re: TeleNav issue

Hi guys - Kenji from Telenav checking in. If this problem persists, please let me know by contacting me at kenjio at telenav.com. I'm happy to help.

Highlighted
Journeyman

Re: TeleNav issue

I have the same problem with Telenav all of a sudden demanding money and thinking I care about premium service.  I have tried reinstalling and rebooting with no benefit. Resetting the phone is not an acceptable solution.

Highlighted
Journeyman

Re: TeleNav issue

Kenji - What information would you need from me?

Highlighted
Journeyman

Re: TeleNav issue

I had this same issue begin yesterday also.  The app is rendered useless.  Any help would be appreciated!

Highlighted
Journeyman

Re: TeleNav issue

I'm having the same issue. I stopped Telenav, cleared the app data, rebooted and updated my profile and rebooted again. Still asking for money.

Highlighted
Journeyman

Re: TeleNav issue

I sent an email in this morning on this same issue. 8/5/12 it worked fine after choosing "No Thanks" on the premium contact screen. On 8/8/12 I tried to use is and now it's stays on the premium screen. Once you choose "No Thanks", Telenav shuts down. No reason or anything.

I've un-installed the original and re-downloaded it from the Play Store. Nothing changed.

Highlighted

Re: TeleNav issue

It might be too late for this to work for you now but I use Astro file manager which has a backup program and I back up each version before I update. This enables me to delete the new version and re-install the old version which is no longer available in market. It has really helped when updates didn't work with my particular phone or were a step backwards.

Highlighted
Journeyman

Re: TeleNav issue

I'm having the same issue.  Mine started about 8/6.  I've uninstalled and re-installed several times but still keep getting the license screen.  Once I click on "Accept", I'm brought to the Premium screen which has the "Buy - $9.99/month", "Buy - $2.99/24-hrs" and "Cancel" option.  If I tap on "Cancel", Telenav closes.

Highlighted
Journeyman

Re: TeleNav issue

Hey all - Kenji from Telenav here again. Our team is aware of this is issue and is looking into it. As soon as I have more info, I'll be back to share. Thanks for your patience.

Highlighted
Journeyman

Re: TeleNav issue

i hope this is not sprints way of now charging all 4 LTE uses for navi because we are all paying for a service that we can't use and I have no problem waiting for LTE but not if it mean we are going to have to pay more for the same apps and services we are use to having.I just spent 2 to 3 hours on the phone trying to fix this only to have not only do a soft and hard reset but now make a trip to the store.I wish that i checked here first because no one at sprint customer service even know about this problem

Community News

Our Community is currently set to Read Only due the pandemic's affect on our staffing .
Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance please visit Sprint Chat