cancel
Showing results for 
Search instead for 
Did you mean: 

Wifi won't stay off!

GrandMaster

Re: Wifi won't stay off!

did you turn off google locations services under advanced wifi? should be under "allow wifi scanning".

*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Journeyman

Re: Wifi won't stay off!

Always Allow Scanning is turned off, as are all of the other options under Advanced WiFi. I have had these options off since before I started this thread. =(

GrandMaster

Re: Wifi won't stay off!

im running a different phone but i remember there was also a google option i had to select when i first got my phone..for the life of me i cant remember where to go to find it. but it assisted with locations as well as connections if im remembering right.

*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Journeyman

Re: Wifi won't stay off!

One more thing.  The solution presented earlier of "forgetting" WiFi networks is not an acceptable solution for me.  I need the ability to connect/disconnect to a WiFi network as needed.  This was never a problem with this phone before the terrible Connection Optimizer was forced on us, or any of my previous phones.

One of the big reasons why this is a problem for me is because I work as a programmer and database admin for a school system.  The school system is fairly small, however.,, so our network is not very large.  Because of this, we have one rule set for sites that are blocked and they apply to the whole division.  Any sites associated with "hacking" are blocked because we do not want students researching ways to hack our network.  However, many resources that I use for "programming" are also associated with "hacking" (this is a common false positive in my field), and those sites are blocked from my work network.  I use my data plan to visit these programming sites and conduct research, and the people I work for know that I do this.  They are glad I have a way to do the research I need while still being able to filter sites from students.  With this update, this is a major chore for me now.  It makes my work MUCH more difficult.  There are times when I need to be on my work's wifi network, and there are times when I need to be on my data plan for research purposes.  I no longer have this control.

Highlighted
Journeyman

Re: Wifi won't stay off!

@fireguy Thanks for the help!  😃  I think the "Always Allow Scanning" option might be what you are talking about, but I don't know.  The description says, "Let Google Location Services and other applications scan for Wi-Fi networks, even when Wi-Fi is off."  I always keep this option unchecked.

GrandMaster

Re: Wifi won't stay off!

pulling in another Sammy fan that might know whats going on.

mmark271_

anything popping to mind on this? i think it might have something to do with google connections but then again im not fully up to speed on Sammy devices so there might be something else in there causing this that i have never ran across before. thoughts?

*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
GrandMaster

Re: Wifi won't stay off!

no thats not the one..it was something else when i first picked up my new phone and was loading all the updates and whatnot..GAH its right there in my noggin on what it was but i just cant grasp it..bah..if my brain eventually cooperates with me i'll post what it was lol. might work..might not..at this point all were doing is reaching for straws/punting to hopefully get closer.

*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
GrandMaster

Re: Wifi won't stay off!

one additional thing..was this an issue before the Lollipop update or after?

*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Wizard

Re: Wifi won't stay off!

I'll assume that you also have unchecked the "Smart Network Switch" in WiFi -> Advanced menu?  That wasn't mentioned in the posts above.  It's kind of a Google added (or Samsung added) Connections Optimizer that is causing lotsa issues on the S5 with 5.0.

This sure sounds strange.  If Connections optimizer is off (go to that menu, uncheck, back out and don't go back) and this Smart Network Switch is off, then there should not be anything that's kicking it back on.

Here's an alternative option that might work for you.  You could use an app called "Trigger" that allows you to set up buttons/shortcuts for connection to and "forgetting" the WiFi network, granted you know their SSID and passwords.  I know you said that this wouldn't fix your issue, but it would allow you to hop on to those testing networks, then hop off when you hit the Forget WiFi button.  I use this for my neighbor's house because his network is juuuust barely in range and causes issues with the networks if I'm over there, then head back home, etc.  I just connect to and then forget through a single tap.

Journeyman

Re: Wifi won't stay off!

Before Lollipop.  The first time I saw it happen was after a Sprint update, though.  I remember it asking me to accept some legal jargon concerning the Connection Optimizer right after the update.  The same thing happened to a friend.  She installed her update at a different time, but noticed the exact same behavior after that update.

Journeyman

Re: Wifi won't stay off!

Thanks, mmark!  I have all of the checkboxes unchecked under Advanced Wifi, including "Smart Network Switch" and "Always Allow Scanning".  Thanks for recommending "Trigger".  I'll check it out and give it a try.  My preference would be to have this working the way it was pre-update, but this app sounds a lot better than what I have been doing.

Journeyman

Re: Wifi won't stay off!

Did this ever get resolved? I'm having the same issues on the Sprint Galaxy S5 Sport and have tried everything; disabling smart network switch, wi-fi scanning for location, connections optimizer, etc., and CANNOT keep Wi-Fi from turning back on.

This is especially problematic for me because I'm traveling internationally and it is destroying my battery while I'm out because it keeps looking for networks. It turns on every 30 seconds or so no matter what I do.

Community News

Need Help? 
Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base.
If you have an account question you can create a post and one of our Social Care Agents will help you.
If you need immediate assistance please visit Sprint Chat