cancel
Showing results for 
Search instead for 
Did you mean: 

It's baaaaaaack. OWA email password issue has returned

Highlighted
Patron

It's baaaaaaack. OWA email password issue has returned

I am back to having to input my password for my OWA email account again. Email is NOT being pushed. I would call customer service, but the last time I spent 45 minutes on the phone with them only to tell me it was an issue on my end (NOT TRUE!) and that nothing could be done.

I want to smash this phone into a million pieces.

12 REPLIES 12
Highlighted
Journeyman

Weird, I have never had one issue with OWA since day one.. Which version of exchange are you using btw?

Highlighted
Journeyman

It's back for me as well, It would prompt me every 3 or so days to enter my password. I got sick and tired of it and just stopped, however, I should make some time to call and **bleep** at sprint again.

Maybe MR-6 will fix this issue.

Highlighted
Sprint Product Ambassador

It's a vendor issue (Seven) and it happens when one of the servers you connect to forgets who you are.

 

Noted to Sprint / Seven.  Thanks,

Product Ambassador, long time Sprint employee
Highlighted
Journeyman

oh how cute. it happens when the itty bitty server "forgets" who you are.

its a machine!! it can do what it needs to do if it was designed / programmed correctly. clearly some engineer(s) at seven need to have their hands broken so they can never ruin the world with their crappy design and code (i'm joking btw, but seriously: fire them). if Seven can't get it right, then find someone who can. why are we paying you to pay them to do this if they constantly can't get it right. in any other company they would have been fired by now.

Highlighted
Journeyman

Thanks Will!

Highlighted
Journeyman

Yes, I am having the same issues as well. When is this going to be fixed?

Highlighted
Journeyman

It isn't a system-wide problem. Must depend on which server you hit.

Highlighted
Journeyman


@wengla02 wrote:

It's a vendor issue (Seven) and it happens when one of the servers you connect to forgets who you are.

Noted to Sprint / Seven. Thanks,


What about this whole (S7128) notice about the SSL security certificate? The problem is, my OWA account on my Instinct has to be refreshed often times (to force it to push emails) but when this stupid block pops up telling me about this issue and asking if I want to accept it and continue it goes back to my inbox without refreshing. I hit refresh immediately after and I'm right back to this stupid notice about the SSL security certificate.

C'mon, can't somebody fix this stuff?

Gmail and Yahoo accounts have worked fine, but OWA has been a POS the whole time.

Highlighted
Journeyman


@mlblack16 wrote:

@wengla02 wrote:

It's a vendor issue (Seven) and it happens when one of the servers you connect to forgets who you are.

Noted to Sprint / Seven. Thanks,


What about this whole (S7128) notice about the SSL security certificate? The problem is, my OWA account on my Instinct has to be refreshed often times (to force it to push emails) but when this stupid block pops up telling me about this issue and asking if I want to accept it and continue it goes back to my inbox without refreshing. I hit refresh immediately after and I'm right back to this stupid notice about the SSL security certificate.

C'mon, can't somebody fix this stuff?

Gmail and Yahoo accounts have worked fine, but OWA has been a POS the whole time.


I had that problem until I switched my OWA url from http:// to https://. Once I added the 's' for the secure connection it worked. I don't need the 's' when using a web browser on a computer.

Highlighted
Journeyman

It's not just OWA that is getting this problem!!!   My Cox e-mail accounts were working fine until recently, then all of a sudden - BAM - Same error you are getting.    I am constantly being asked to re-enter password (even though it hasn't changed).   Re-entering password does not guarantee that I am going to be able to receive/send my emails.    I have even deleted and re-added one of the accounts (leaving other w/o changes)   - still no joy.

What the heck is going on here????  and When can we expect it will be fixed?   This problem makes the phone totally unreliable to use for e-mail purposes.   Real bummer cause I do love the phone....

Highlighted
Journeyman

Mine is out again as well, and I've tried every fix.  I need to have access to work email!  This was one of the reasons I bought this phone.

How hard can it be.  I don't understand how it can work for months and then go out.

Community News

Our Community is BACK!!
Hours of Operations are 7AM - 8PM CST. Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat