Showing results for 
Search instead for 
Did you mean: 

Can't reply to some text msgs on Moment


Can't reply to some text msgs on Moment

Not sure if this is the right forum, but I've run into an issue.  I've had the Samsung Moment for about a week now and have run into a problem with replying to text messages.

The issue seems to be that when I receive a text message and try to reply, the Moment replies back to the number WITHOUT the area code.  This only happens on inbound texts from specific numbers.  Funny thing is, the Moment knows where the call is coming from because it matches number number with the name in my contacts.

Anyone know how to resolve this issue?  It's frustrating to have to look up the contact and to start a new text msg thread, versus just replying.



Just wanted to add that what's happening is this.  A text comes in from John Smith (410) 555-1212.  This person is in my contacts and the Moment shows it's John Smith.  When I reply to the text it send to number 555-1212. It drops the area code, on the reply so I end up getting an error stating the number I'm trying to text to is bogus.

Message was edited by: crabjoe


Re: Can't reply to some text msgs on Moment

Couple questions:

     -For the John Smith example below - is he in your contacts with or without the area code?

     -Which SMS client are you using?

I personally use Chomp SMS, and I believe all of my contacts have the area code included - but i can't confirm offhand because I have over 400.  Based on your answers i'll see if i can test to replicate.


Re: Can't reply to some text msgs on Moment

All my contacts are in there with the area code.

As for the client, it's whatever that came with the Moment.

I hoping it's not the network, because it happens every time I text the Moment from my Sprint Curve.

BTW, I tried taking out the contact and re-entering it.

Any ideas on what else I might try?

BTW, I don't seem to be able to trash any apps on the Moment. Everytime I drag something to the trash, it's as if nothing happened. The dang app is still there!


Re: Can't reply to some text msgs on Moment

Hrm...this is the first time i've seen this.  I reached out to one of the guys i know on the network side to see if he has an idea if it could have something to do with provisioning.

I'm really not sure about the inability to trash icons thing....maybe some system files got corrupted and your phone is just in a weird state - and it's manifesting itself through multiple problems.

If you don't have a whole lot installed / configured - it might just be worth clean resetting the phone to see if it fixed.  If you want to go that route, it's: Main Screen > Menu > SD card & phone storage > Factory Data Reset

I'll let you know when i hear back from the network guy....


Re: Can't reply to some text msgs on Moment

I had this same issue too.  Basically of all my contacts I had set up in my gmail account, only one of them had a phone number with no area code.  So whenever I would try to reply to a txt from him the phone would kick back an error telling me I used an invalid number of digits.  This kept happening even after deleteing the contact and readding the person with a 10 digit number.  It seems as if the phone had the old data in cache somewhere.

I called sprint for support but the guy I talked to had never even used a Moment before and had no clue.  The only solution I could find was to factory reset the phone.  It's really sad that you have to do this but be very careful never to add any contacts without the area code or you're doomed.


Re: Can't reply to some text msgs on Moment

@Crabjoe - My network guy said that something like this would either be a weird, random network problem that wouldn't be consistent...or something specific to the device.

I would try factory resetting the device to see if it fixes it.  If not, I'd definitely take it into a store.  You could possibly take it into a store now to try and reproduce the problem - but I have a feeling they would direct you to factory reset.


Re: Can't reply to some text msgs on Moment

I had the same problem. The problem occurred when I set up my first or second contact and did not input his area code even though it was the same as mine. Then corrected it and put the right area code. When I would send a txt to him he would get it, I would get his first reply, then I couldn't reply after that. I noticed that when he replied his phone number didnt contain the area code so my reply back never was received.

I went to Gmail and made sure that my contacts all had correct numbers with their area codes. Then I went into settings on my phone and deleted all contacts. I did this by going to Settings\Applications\Manage applications.

On the list scroll down to Contacts and Contacts Storage. Delete both. Effectively wipping out your contacts.YOU MUST DO BOTH!

Then go back to settings and go to Data Synchronization. Uncheck Gmail, then Check it again.

Your phone will take a second and sync with gmail and import your contacts back in. Be sure there are no duplicates in gmail and be sure the phone numbers have the area code in gmail.Once the phone syncs back the corrected gmail contacts you should be fine.

To the sprint rep...I could repeat this over and over with best buy and the sprint store. They couldnt figure it out. But this worked


Re: Can't reply to some text msgs on Moment

Add me to the list with the same problem. I tried to send my very first text to 918344xxxx, AND 918381xxxx without a comma in between. Of course, that gave me an error message. Since then, every time I get a text from him, and I try to reply, it automatically prepends 918381xxxx with the 344 number, and gives the error again, and the text fails. I agree with it being a cache issue.  How about a fix in android 2.0? the sooner the better. In the meantime, i bit the bullet and reset.


Re: Can't reply to some text msgs on Moment

Can those that are impacted confirm whether the same issue exists when using ChompSMS or Handcent as the SMS client?

This would confirm if:

     -issue is either device specific or specific to certain contact configurations

     -it is a bug in the default messaging app, that would need to be fixed by Samsung/Google


Re: Can't reply to some text msgs on Moment

I have the same exact problem when I try to reply to my brother's messages.

It's strange that it ONLY happens with him though. 


Re: Can't reply to some text msgs on Moment


Alrighty, after some trial and error at 1:20 in the morning, I think I've figured it out.  Great first post, eh?

Anyways, when using ChompSMS or HandcentSMS, if the message is sent to you, Chomp/Handcent replies to whatever number it was sent from.  Alrighty..I cleared out my history in "Messaging", deleted my contacts/contacts storage in settings\applications\manage apps, and unchecked/checked gmail and contacts in settings\data sync and it works.  I can now send/receive texts from the number I was previously having troubles with.

THE "CACHE" IS IN THE MESSAGING APP.  Until I deleted all texts in the messaging app from the phone number I was having problems with, it wouldn't work.


Ensure your contact has a 10 digit number, clear your "messaging" app from all texts (all texts just to make sure), clear your contacts\contacts storage, unsync\resync your gmail and contacts.  Viola!

Worked for me, atleast.  Without a factory reset.


Re: Can't reply to some text msgs on Moment

I had the same problem with the text msg dropping the area code also. I downloaded the "handcent sms" app and have not had a problem since.

To trash the apps that you have downloaded: Go to settings-->Applications-->Manage Applications-->click on the application and uninstall.

Community News

Need Help? 
Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base.
If you have an account question you can create a post and one of our Social Care Agents will help you.
If you need immediate assistance please visit Sprint Chat