cancel
Showing results for 
Search instead for 
Did you mean: 

Having trouble with Android 2.1 USB Debugging Drivers? Fixed!

Journeyman

Having trouble with Android 2.1 USB Debugging Drivers? Fixed!

After countless hours with Sprint, and more countless hours on the web, here goes...

I have the m900 Moment. Updated to Android 2.1.

Problem: Could not get drivers while debug mode was activated.

Solution: FINALLY found some drivers that worked, uploaded them here:

http://uploading.com/files/6de7c2da/Samsung%2BMoment%2BUSB%2BDrivers%2BWindows%2BWorks%2Bwith%2BAndr...

I know, slow download, but hey! It is free.

I hope this helps all of you with the same issue. Sprint and Samsung say it is a "known Issue" and they are working on it. I am too impatient, and rely on my PDANet .

I use WinXPpro, Samsung Moment, fresh install Android 2.1 from Sprints Website.

Good Luck!

3 REPLIES 3
Wizard

Re: Having trouble with Android 2.1 USB Debugging Drivers? Fixed!

Did I misunderstand, or are you complaining that Sprint has not made it easy enough for you to use a third-party program to tether, when your Sprint plan specifically disallows tethering?

Journeyman

Re: Having trouble with Android 2.1 USB Debugging Drivers? Fixed!

No. Let me break it down for you. What I said was (and I quote):

Problem: Could not get drivers while debug mode was activated.

What that means exactly: Could not get drivers while debug mode was activated.

Just a simple function that was intended for those of us out here that want/like it can use for other things, such as app development.

Maybe I am mistaken, but, I am sure this is why USB Debugging is located and can be check marked on/off in the Development section of the application settings on the m900.

My complaint was that simply none of the guru's at Sprint had any idea on how to make Debugging work, or, just diddnt want to make it available.

The PDANet comment (including the smiley face) was meant to be funny.... place a check on your sense of humor, and if the post does not apply to your cercumstance, then simply do not reply.

Wizard

Re: Having trouble with Android 2.1 USB Debugging Drivers? Fixed!

First, since from what I have read, debug mode is required for at least some devices to use PDAnet, it was not completely out of the realm of possibility that your PDAnet comment might actually have something to do with the paragraph and post within which it was included.  Even re-reading your post with your explanation that it was a joke, it still clearly appears that the reason that you were upset about your problem was because you rely on your PDAnet, and it would not work until you got your problem solved.

Second, your problem as stated, "Could not get drivers while debug mode was activated." could not possibly be solved by your stated "Solution: FINALLY found some drivers that worked", as if you cannot get drivers, a different driver could still not be "gotten".  Maybe an unclear statement of your problem had something to do with why you could not get what you considered to be adequate assistance from "the gurus".  If you are trying to help others with your post, a clear explanation of the problem is necessary for them to know if they are experiencing the same problem as you.

Also, since you claim you are an Android application developer and your post was related to that activity, you may have noticed that very few other application developers use this site for help in application development.

Community News

Need Help? 
Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base.
If you have an account question you can create a post and one of our Social Care Agents will help you.
If you need immediate assistance please visit Sprint Chat