ForumTopicPage
cancel
Showing results for 
Search instead for 
Did you mean: 

My browser thinks I'm French

Journeyman

My browser thinks I'm French

I have Google.com set as my home page.  Every time I open the browser, I have to select "Google.com in English" at the bottom of the page because I don't speak freaky-deaky French.  I tried "Enable location" to see if maybe it thought I was somewhere in France and that made no difference.  Sign out/signed in, no difference.  What's going on?  Am I missing something obvious?

7 REPLIES 7
Journeyman

Re: My browser thinks I'm French

My browser sometimes thinks I'm German.  It has ever since I used the phone in Germany with WiFi.  I have no clue how to resolve it but thought I would let you know you aren't the only one.

Journeyman

Re: My browser thinks I'm French

German would be nice.  I can at least speak that a little bit.

Journeyman

Re: My browser thinks I'm French

Mine was in Japanese for a while, so I'm glad that it's now French, as I can read that!  Yes, I can click "English", but it is a bother...

Journeyman

Re: My browser thinks I'm Mexican

I go to Mexico frequently. I speak Spanish apparently.

Journeyman

Re: My browser thinks I'm French

Headlessponch wrote:

I have Google.com set as my home page.  Every time I open the browser, I have to select "Google.com in English" at the bottom of the page because I don't speak freaky-deaky French.  I tried "Enable location" to see if maybe it thought I was somewhere in France and that made no difference.  Sign out/signed in, no difference.  What's going on?  Am I missing something obvious?

I don't have a samsung but see if this helps. The menu settings may give you the option to select the language.

Setting the Browser Home Page
1. Press to open the browser menu.
2. Tap More > Settings > Set home page.
3. Delete the current address and enter a new web
page.
4. Tap OK to complete the process.
Resetting the Browser to Default
1. Press to open the browser menu.
2. Tap More > Settings > Reset to defau

Wizard

Re: My browser thinks I'm French

From the Google search page, try "Settings" at the bottom of the page (on the Google page, not the phone menu); then "More settings".  You should see options there for "Interface Language" and "Search Language".  At the bottom of that page, make sure you scroll to the right to find the "Save Preferences" button.

Journeyman

Re: My browser thinks I'm French

What I ended up doing was typing in google.com/en and setting that as my homepage.  I thought I'd looked through the "Settings" options, but I obviously missed the "More Settings".  Thanks anyway.

Message was edited by: Headlessponch

Community News

Need Help? 
Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base.
If you have an account question you can create a post and one of our Social Care Agents will help you.
If you need immediate assistance please visit Sprint Chat