Showing results for 
Search instead for 
Did you mean: 

Seems to be a screen issue or OS issue


Seems to be a screen issue or OS issue

Lately I have not been able to unlock my Moment because when I try to draw the patter the screen goes haywire and then the phone locks for 30 seconds. After this I can then put in my email password to unlock it. However, after it is unlocked I cannot do anything because no matter where I click or what button I push it acts crazy. I have had to reboot the phone multiple times then leave it off for 10 minutes. ONce turned back on it worked fine for a few days and then acts up again.

I recently took the phone to the store and they upgraded the OS. For the first few hours it got worse, then it improved. It still acted like it did before the upgrade but it would only require one restart as opposed to multiple ones.

Now, a week later it is acting like it did before the upgrade. I have had to disable the secure pattern so that when it acts up I can shut it down easier. I have also tried removing the battery and replacing it 10 minutes later. Everyday at least twice a day I go through this.

It becomes a problem when I am driving. I have also noticed that I lose all signal strength for no reason whatsoever. I can be standing in one spot and be one the phone for 10 minutes then all of a sudden for a couple minutes I have no signal.

Is anyone else having issues like these?

Community News

Sprint S.M.A.R.T Agents
Sprint S.M.A.R.T Agent are here to help Monday through Friday 6:00 AM CT - 6:00 PM CT. If you need to speak to an agent outside of these hours, please visit Sprint Chat