cancel
Showing results for 
Search instead for 
Did you mean: 

Galaxy S7 Caller ID won't show up on other end

Journeyman

Galaxy S7 Caller ID won't show up on other end

Since my phone updated to 8.0, whenever I call someone, it pops up as "Restricted" or "Anonymous".  It used to show my name.  Does anyone know how to fix this?  I went to a Sprint store yesterday and they could not fix it.  Thanks for any help.

5 REPLIES 5
Wizard

Re: Galaxy S7 Caller ID won't show up on other end

Wow, that's weird! Lets figure this out together! Have you made sure that it's enabled in your settings to show your name when you call? If not here's a link showing the steps in order to do so http://deviceguides.ee.co.uk/samsung/galaxy-s7-edge-android-7-0/calls-contacts-messaging/turning-you...

 


QueenK Social Care 

Be Original, Not a Copy. 
Your opinion matters! So feel free to show someand accept the solution once the issue is fixed!
Journeyman

Re: Galaxy S7 Caller ID won't show up on other end

After step 4 of clicking on more settings, I don't have the next screen.  My more settings has TTY mode, hearing aids, US dialing.  Nothing about turning caller ID on or off

Wizard

Re: Galaxy S7 Caller ID won't show up on other end

Ok lets hop on over to private message so I can get some more info.

 


QueenK Social Care 

Be Original, Not a Copy. 
Your opinion matters! So feel free to show someand accept the solution once the issue is fixed!
Journeyman

Re: Galaxy S7 Caller ID won't show up on other end

I'm having the same problem.  Were you able to get it fixed?

Journeyman

Re: Galaxy S7 Caller ID won't show up on other end

Yes.  I got on the chat with a Sprint representative on the Sprint website and they did something that got working.  Give that a try.

Community News

Sprint S.M.A.R.T Agents
Sprint S.M.A.R.T Agent are here to help Monday through Sunday 6:00 AM CT - 6:00 PM CT. If you need to speak to an agent outside of these hours, please visit Sprint Chat