cancel
Showing results for 
Search instead for 
Did you mean: 

How to permanently disable chat mode of rcs enhanced messaging

Go to solution
Highlighted
Journeyman

How to permanently disable chat mode of rcs enhanced messaging

My daughter and I both upgraded our phones, I got S8 and she got MotoZ2 Force, and I found the new chat feature on my phone to be extremely annoying. I would send her a text and she wouldn't get it until much later, sometimes a couple of hours. Then I realized it was because Messages was set to "Chat" as default message type in settings, so instead of sending our messages as SMS it was trying to use data.  So while I was able to switch it off by changing the default type to "Text/Multimedia" in the Messages app settings, it still defaults back to "Chat" by itself, but not right away...it will reset back to the Chat setting later, like after a couple of hours or completely closing it out, like it's playing a joke on me! I would like a way to permanently disable this feature so we can just text normally via SMS/MMS.  This really gets annoying having to check the settings in Messages to make sure the default message type is "Text/Multimedia" every single time!

2 REPLIES 2
Wizard

Re: How to permanently disable chat mode of rcs enhanced messaging

You might make sure you have the latest version of the messaging app so I would recommend that you have a Samsung Account setup. Then just go to the Galaxy App Store and check for updates for the default Samsung Apps.. That being said changing the default inside the app it should stay to whatever you choose. Keep us updated.. Smiley Happy 

Journeyman

Re: How to permanently disable chat mode of rcs enhanced messaging

I have finally figured it out:  You have to ALSO disable the Rich Communications settings!  Before, I had only set the default message type to "Text" without also turning off the Rich Comm.  So in the Messages Settings tap Chat Settings, toggle 'Rich Communications setting' button off AND set your 'Default message type' to "Text/multimedia msgs".  Now I no longer have to check to make sure all my messages are set to "Text", it doesn't switch back to "Chat" by itself anymore.

Community News

Sprint S.M.A.R.T Agents
Sprint S.M.A.R.T Agent are here to help Monday through Sunday 6:00 AM CT - 6:00 PM CT. If you need to speak to an agent outside of these hours, please visit Sprint Chat