cancel
Showing results for 
Search instead for 
Did you mean: 

Note 10 message over WiFi

Highlighted
Journeyman

Note 10 message over WiFi

I see this problem all over the message boards for Sprint and Samsung. When you speak to Sprint they act like they have no idea what you're talkin about. I replaced an LG G5 had no issues ever doing messaging with attachments over Wi-Fi did not ever have to use mobile data. From what I see there were glitches in the phones that were manufactured prior to November of 2019 that can't be fixed by changing any settings or any patches. I am so frustrated I just want to throw this phone in the garbage. I have 2 gigs of data a month and I am not going to spend $30 extra a month do you have unlimited data when I don't need it. I spoke to Samsung's customer support and they acted like they had no idea what I was talking about

16 REPLIES 16
Highlighted
Sprint Social Care

If you are having issues sending it over Wifi you can switch to data and it works! 

Highlighted

You didn't read what I wrote. I do not want to have to use mobile data to send an MMS message. I do not have unlimited data on my plan. I have never had this issue prior to this phone. There are numerous posts and notes all over Sprint website and Samsung's website about this issue and there was a glitch in these phones made prior to a certain date. The background data is turned on in the app itself for messaging. It will not work unless you turn on your mobile data for MMS messages with any type of picture or attachment

Highlighted

thats because the phone must drop back to regular data to authenticate first..no data connection means no authentication. and correct this mainly affects Samsung devices from what i can tell.

 

you might also try using Google Messages to see if it still needs that authentication or not..if it doesnt then you are good to go with a different method. if it does then its back to the drawing board.

*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Highlighted

Thanks I'm not sure if I tried Google messages yet I'll give that a try it's just so frustrating that Sprint and Samsung says they have no idea about this problem yet it's everywhere

i know i can still do it on my LG G8 that uses Messages as the texting app..i keep forgetting to turn my data off then try it..at my home im in and out of reception so its usually a decent place to test against things like this.

*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Highlighted

Hi thanks I just did try Google messages same issue tells me to turn on my mobile data I just think it's a glitch with this phone and no one will admit to it!

Highlighted
GrandMaster

thats while connected to wifi? double check the settings and advanced settings in the Google one to make sure you dont have to turn something on in there.

*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Highlighted

I've checked all the settings and it still comes up that mobile data needs to be turned on.  As soon as I allow mobile data it goes right through. I read on one of the threads that there is a software problem if the phone was manufactured prior to a certain date and there is no fix for it.

Highlighted
Community Manager

I think there is some confusion here.  If you are sending MMS on Sprint, mobile data has to be on because the device has to drop down to the mobile layer to authenticate who you are to send and/or receive MMS.  All of our devices operate as such.

 

There are problems with Samsung S8, Note 8, S9, and Note 9 that did not drop to mobile at all while on wifi and as a result, no MMS could not be sent out while on wifi.  I've been told the Android Message Yeti version addresses this.

Highlighted

The "allow background data" within the app is on. The problem is if you go to send a message over Wi-Fi and you do not have your mobile data on it has an error that indicates that the message will not be sent unless you turn on your mobile data. It MMS formatted messaging. I have tried three other messaging apps and it's the same issue . There was a fix that address this for Note 10 phones manufactured after I think November of 2019. If the phone which obviously I have was prior to that date there is no fix for this issue. I do not have unlimited data and I am not going to pay extra per month to have it. As soon as I turn on mobile data the message goes through. I have never had this issue before this phone. I had an LG G5 for the past 5 years that I never turned on my mobile data unless I was on a long trip that I didn't have any Wi-Fi to hook into. I always sent any type of message over Wi-Fi. I've spoken to people at Sprint tech who all act like they've never heard this before. It's all over every Sprint and Samsung message board. I just have to have the energy to deal with Sprint and escalate this up to someone that will switch out this phone for me to a different manufacturer. I am pretty tech-savvy and have changed every setting and done every adjustment that is available  to my knowledge, with no luck.

Highlighted

There is no need to escalate anything, it is exactly how I described above in my first paragraph:

 

If you are sending MMS on Sprint, mobile data has to be on because the device has to drop down to the mobile layer to authenticate who you are to send and/or receive MMS.  All of our devices operate as such.

 

This is not an issue, this is by design.

Community News

Our Community is BACK!!
Hours of Operations are 7AM - 8PM CST. Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat