cancel
Showing results for 
Search instead for 
Did you mean: 

Hulu validating my sprint account

Go to solution
Highlighted
Journeyman

Hulu validating my sprint account

I was trying to add the free hulu plan to my phone. After I added it, they sent a link to validate my sprint account but it would always end in them saying there was an error and to check account status. I then decided to wait 1hr because that's how long they said it would take for the plan to show up on my account. I checked an hr later and it was there, so I tried the link and I still got the error message. As of late, I think I tried the link too much because now they're saying "request entity too large". Also, I've made sure to turn off wifi and I've tried removing and re-adding hulu as well as resetting my phone, still no luck. Does anyone have any clue on how to fix this?

20 REPLIES 20
Highlighted

I already added hulu to my plan, and yes I've tried removing and re adding it. The problem is with the link they text me, when I click the link, it tries to verify my sprint account and fails.

Highlighted

Have you tried clearing your browser cache or copying the link and opening in a new private/incognito window to try and finish the process? It could be that when you initially ran through before things were solidified that your browser wants to keep taking you back to the error page. 

 



"Hail Yourself!" - Ben Kissel


Highlighted

Just tried, it didn't work.

We can try and resend you a new link. I'm going to send you a private message so that we can get your account info to get that out to you. Keep an eye on your inbox here. 

 



"Hail Yourself!" - Ben Kissel


Highlighted

I’m having same exact issue. Help would be appreciated.

Highlighted

I removed hulu from my service. (You have to wait at least an hour to readd it) and restarted the whole process, it worked. Maybe it was a coincidence, but the only thing that was different was that I just paid my bill. The first time I tried it, I had an overdue bill that I partially paid but my phone was still on, so I thought it would work. So make sure everything concerning your account is in order (this includes yours and any other lines that are on your account), other than that, I can only advise the basics, make sure you followed the instructions completely, make sure your wifi is off and your phone internet is working. Hopefully things work out for you!

View solution in original post

Highlighted

Figured out the problem and solution, have to clear browser history, for some reason causes problem. After that turn WiFi off and then clicked the link inside my messages. 

View solution in original post

Highlighted

Thanks for sharing what worked for you. This is always helpful for new visitors who join the Sprint Community looking for these same answers!

 



"Hail Yourself!" - Ben Kissel


Highlighted

I had the same page but none of the other stuff about the bill applied to me. The incognito tab worked just fine. 

Community News

Our Community is BACK!!
Hours of Operations are 7AM - 8PM CST. Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat