cancel
Showing results for 
Search instead for 
Did you mean: 

Treo 800w Vision connection problems

Highlighted
Journeyman

Treo 800w Vision connection problems

I have a Treo 800w and it seem to have connection problems to the internet (mobile web) every time I turn on the phone from off to on mode. This is occurs mostly when I travel by plane and land in a new city and turn on the phone and try to connect. It shows like it's dailing #777 (dials to Sprint Vision) forever and says connecting, but never actually connects. After a while it gives me an error saying there is no connection. I then have to do a soft reset by taking out the battery and putting it again and turn on the phone all over again. Then the internet finally connects.

Does anyone have any idea(s) as to the cause and a possible solution? And I don't think it's the network's fault. It seems like a Treo problem.

Any help would be great. Thanks.

3 REPLIES 3
Journeyman

Re: Treo 800w Vision connection problems

The best solution is to buy a new phone. Seriously, I had an 800w until a few months ago, and had exactly the same problem you describe when travelling (which I do often). I also had many other problems with my 800w, especially related to communications. I switched to the Touch Pro2, and all of my problems went away, including the one you describe.

In the meanwhile, I did find a workaround that sometimes works. When you land, before you try to use a vision connection, place a regular phone call (to anyone) and make sure it connects, then hang up and try the vision connection. This seemed to work for me about 80% of the time ... it's almost as if the phone needs something to help it figure out where in the world it had travelled to.

Journeyman

Re: Treo 800w Vision connection problems

I have had this problem with the Treo just jumping into the dialing of the 777 number and always thought it was just me.

Thnaks for bring this up, glad to see it isn't just me.

Journeyman

Re: Treo 800w Vision connection problems

This is the most useless phone I have ever had. I have had to have it replaced three times by Spint already. I have to do the soft reset at least twice a day. The phone is just completely awful, as is Sprint's customer (dis)service! When my contract is up, I'm off to a different company

Community News

Need Help? 
Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base.
If you have an account question you can create a post and one of our Social Care Agents will help you.
If you need immediate assistance please visit Sprint Chat