cancel
Showing results for 
Search instead for 
Did you mean: 

How to fix iPhone 5 3G Data Problems (Confirmed to work)

Highlighted
Journeyman

How to fix iPhone 5 3G Data Problems (Confirmed to work)

We fixed the 3G problem on one of our iPhones this past Sunday.  I would've posted earlier, however, I was advised to wait until today to confirm that the fix works (and it has worked flawlessly since).  It turns out Apple never loaded the "activation policy" that links the serial number of your phone to work on the carrier on our phone.  This is not the same as the SIM lock and is something done on iPhones on their own internal system.

We finally reached a Sprint Tech (ky158151) whom had the foresight and acted on his inclination.  He called Apple on our behalf and was advised indeed the activation policy short.  The tech put the request in to load the activation policy on the phone.  After we got the confirmation that the policy has been loaded we performed a factory reset and set up the phone as new.  15 min later, VOILA! Data!

I would contact Apple first.  The senior rep that I dealth with (REDACTED) whom also can be reached at 1-877-REDACTED.

Please provide them your serial number, ICCID, MEID, as well as your phone number when you contact them to request loading the activation policy that's linked to your phone.

I really hope this fixes it for all of you out there.  The frustration going through this really was something.  I just cannot something like this actually fell through the cracks before shipment.

90 REPLIES 90
Highlighted
Journeyman

I'm glad others are seeing some positive responses.  My heart goes out to those without data still.  It was terrrrrrrible!

I think after the many many many times sprint said the "tower" is out (when I was speaking to them on our other (working) iPhone5"........they must've jynxed it.

Tower is really out now   It's going on roaming (Extended Network)....I guess time for another call.......sigh.....

Highlighted
Journeyman

EVERYONE, CALL APPLE.

tell them to check to see if the carrier is listed as (your carrier) or (cdma netowrk)

if it does not say (sprint) and it says (cdma network) then you most likely have the 3G connectivitiy issue where it says "could not activate cellular data network"

ask to speak to a senior rep at apple and have them go over your IMEI, ICCID, MEID, SERIAL NUMBER etc.

tell him to have the policy/profile loaded

he will then say ok or whatever and then tell you 24-48 hrs

i restored my iphone after 22 hrs and IT WORKED. i drove up the street to test 3g, i walked in and out of my house and so on and so forth. it seemed faster btw , but my resutls will be different. everyone should manually restore their iphone now just to see if apple and sprint worked together and loaded the activation policy onto the apple servers .

Highlighted
Journeyman

I too restored the phone through iTune several times and did not work. I called Apple and even had them look at the threads here but the rep said he had never heard of it, and said that by restoring the phone the activation policy should be pushed through. He told me to try it again through iTune and call him back if it doesn't work; even opened a case number for me and left notes on it so I won't have to start over again when I call back. Then today while I was driving home, I received a call from a Sprint ticket agent because I insist on them doing more research on my account eventhough they claim it's the capacity of the tower and the hardware problem. The agent told me to Erase All Content and Setting, the hard reset option, and leave the phone off for at least one hour. I was skepitcal at first that this might work since I've done the hard reset and ##873283# numerous of time, and even went back to my EVO for several days and it did not work. However, this time it worked. I waited almost four hours then turned on the phone and activated it over wifi, and restored using iCloud. My ping is 91 ms, 0.60 Mbps down, and 0.82 Mpbs up now. Not fabulous, but a lot better than before; 899 ms ping, 0.04 Mbps up, and 0.00 Mpbs down. The internet is usable now too. I suspect that they did something to my account and just need me to reset and turn off my phone to let whatever hold or setting to release, then activate my phone again. They asked me to call back once I got it working so they can confirm whatever they did works, and I'll do so first thing in the morning tomorrow. Sprint is really trying to fix this problem now. You just need to insist them on looking deeper into your account. Hope this helps!!

Highlighted
Journeyman

Thank you JoeFrosty for figuring out the problem.  My phone is now getting 3G at around 1.5Mb/s and I almost returned this phone today!

Hoping Apple may have fixed the problem over the air last night, I restored the phone and it still remained in the 3G-circle purgatory.  I called apple and asked for a senoir tech rep.  He confirmed that there's something wrong with the activation profile.  He then set up an internal request to have an engineer to fix it and told me to restore again this afternoon.  My heart sank once again seeing that little circle this afternoon and called another rep.  He then up the priority of the issue with the engineers and whipped up some Cupertino magic.  Few hours later, I got a phone call from the first senior rep saying that there's a confirmation from the engineering department that the activation profile is indeed fixed.  The phone was restored once more and voila, 3G! 

Hang in there everyone. Restore your phone and see if it's already been corrected.  If not, call apple and ask for a senior rep. This works!

Highlighted
Journeyman

joycium1104:

I'm so glad it worked out!!!  Can you believe that my phone never had problem? and it was my wife's phone who had this issue?  Marriage sucks!!! But she's an attorney so she needs that data/e-mail more than anyone!

What pisses me off is I called Sprint to report a tower outage and I thought I was doing a favor by informing the first tier (claimed to be iPhone specialist) tech support about the solution of the problem.............All I got is arrogant responses..........where the rep stated that it's the SIM ID that's messed up.

Anyway, I spoke with her manager (not at my request) and they were basically profusely thanking me for telling them of the solution for this BS.

Highlighted
Journeyman

this is funny I am on the phone with an Apple sinor rep right now as I type this and to be honest he's never herd of the activation policy problems and told me to contact Sprint because it is there kind of problem. Also as I am speaking to him he is typing to another person and ended up putting me on hold for 3-4 min just came back on the phone and told me he is going to call me back with in an hour because he is going to look into this activation policy problem and to see if other problems on our end that our end could be causing the service to not work right he said and is going to call me back. so I will keep you updated

Highlighted
Journeyman

Apple rep called me back today.  He confirmed that the activation profile is now loaded.  He said to turn the phone off for 15 minutes and see if it is OK and if that didn't work, to do the backup/restore.  After 15 minutes, no-go, but after the backup/restore - FIXED!!!  Don't really know why he would suggest the 15 minute option.

Also, FYI, I didn't do the activation between the backup/restore.  I just did a backup, then chose restore which reloads the OS/firmware, then after reboot, chose restore again with the previous backup.  After restarting, it showed "Waiting for Activation" for a couple of minutes, then went to activated status.  The first hit on a web page in Safari quickly showed the dreaded "o", but then jumped right to 3G and stayed there.  I was able to load web page after web page and they all came up (fairly) quickly on 3G. 

This problem is now fixed!  It's a shame that it took from launch day of the iPhone 5 until today to get it fixed.  In the end, this did end up being an Apple problem with not having the activation profile loaded, but Sprint should have been able to figure this out.  Also, shame on Sprint for repeatedly telling me at least a dozen times that someone would call me back to resolve the issue and they never did.  Yes, one person there did finally give me a call this last week to follow up, but he was unable to resolve it and passed it to someone else who he said would call me - and they didn't.  Come on Sprint, own the problem!  The first thing the Senior Apple Advisor told me was "My name is Clay and I own your problem until it is resolved".

Highlighted
Journeyman

Glad it worked out for you.  Sprint rep called me today also and stated that my profile was loaded buuuutttt..... sprint did not respond back to apple engineers. So the rep told me I might have to call sprint and have them possibly reprovision my line...yeah like that's gonna happen...tried before and was flatly told no.  Anywho, the rep told me to go ahead and do a backup/restore and set up the phone via itunes.  Did all that, and signal seems crappier now. I keep getting the "no celluar data available..." bs message.  Rep told to have my roaming set to voice/data. Did that, the circle of death was steady...shut off roaming data, 3g comes on.

But the 3g was pure crap...2145 ms, 001mbs d/l  000 mbs u/l.

I don't understand for the life of me, why I went with the iphone 5. Should have stayed with my android HTC EVO.

Why is it so diffcult for Sprint to get its act together with the apple iphones. They wanted it so bad, sold the farm practically just to get the iphones, and they can't deliver a stable data service. Why offter unlimited data plans on the iphones? There is no data to be used in the first place!

My rant for the night...

Highlighted
Journeyman

I'm in the same boat. I've had the phone for a month and still no data whatsoever. Have had the phone replaced and have spent at least ten hours on the phone with Sprint tech support so far. The account management supervisor told me she wouldn't lower the activation fee or help in any way because the phone was only failing on 1 out of the 4 things it does. Unbelievable!!!

A smartphone without data is worthless to me, utterly worthless. Sprint have offered nothing in the way of help to get me out of this mess. Meanwhile I'm unable to get work emails or documents on my phone, something that is critical to how I perform business.

Sprint have not helped and despite me offering to split the termination fee 50/50 wouldn't even budge an inch. Horrible customer service story so far.

I have a ticket open with the Better Business Bureau in Kansas in the hopes that they can help bring some reason to the situation.

Highlighted
Journeyman

BlakSkyz,

I'm in the same boat. I have a > 3 second ping with 0.01 down and 0.00 upload. It's unusable. The technicians have confirmed that the towers in our area are over capacity and that upgrades aren't expected to complete until the end of next year. I have NO DATA...on a smartphone! It's useless to me and the Sprint reps are doing nothing to help the situation.

I'm so frustrated with this company right now. What a horrible customer service experience. They always were the worst in customer service and it looks like absolutely nothing has changed since then.

It's looking more and more likely that I'll have to walk away, eating the cost of the phone and the contract termination fee (if Sprint have their way). It's utterly ridiculous.

Highlighted
Journeyman

I am  still having issues with my iPhone 5. This is my 3rd one and still getting the 3G to "o" problem. I have called  sprint tech support three time they tell me there is no reported issues. I went to the apple store today and they told me it was not a apple issue but a sprint network problem. Even though they said is was a sprint problem they replaced the phone. The new phone is still doing the same thing, 3G to "o". If anyone out there has a sprint tech support person that could help me. Please reply to this post or  email me SarahKS removed personal info].

Highlighted
Journeyman

My iPhone 5 shows 3g with all bars but I get no data. I have tried everything that has been spoken about here. Sometimes I get data back for a few minutes but then nothing again. This is getting quite ridiculous. I have to find wifi if I want to use my iPhone for data at all. Most of the time I can't even text someone. This is obviously a Sprint issue because until a week ago I had no data problems whatsoever. FIX THIS SPRINT!!

Community News

Our Community is BACK!!
Hours of Operations are 7AM - 8PM CST. Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat